CTF-[R3P]-W007-III Fail.

Tutorials and discussions about Mapping - Introduce your own ones!
User avatar
R3plicant
Experienced
Posts: 93
Joined: Sat Jul 21, 2018 1:31 am

CTF-[R3P]-W007-III Fail.

Post by R3plicant »

The (flawed) map file is linked here


Well, I don't know what to say. I have had to see sense and realise I'm just not a good mapper. This is a 'sense' quit rather than a rage quit, I see no more sense in trying to get this map to work; it's a failure as it persists in lagging in-game, in both SP and in MP modes despite my very best efforts and the efforts of others who've helped me. It's unplayable in its current state.

The map is lagging like a ***** and I just cannot for the life of me, work out what's actually causing it. I've spent many, many hours working intensely with the brilliant, patient Buggie, ridiculously clever Aspide and bot-pathing god Sektor and had advice from Hourences and Lode to hopefully get the map to state that I was happy with but I realise now that's not gonna happen, the map is, somehow, fundamentally flawed and I cannot work out why.

My only guess is it's a poly count issue, I know it's a busy map with lots of beautiful detail (if I say so myself) - did I push the engine too far? *Rhetorical question. The simple answer to my own question though is: Maybe, yes.

The map file is linked here with all the associated files. If you want to try and get it running smoothly, by my guest, I want no more to do with it. The link won't be active for too long so I suggest you save it and maybe make it available elsewhere but with this post attached so people know why it's being made available.

If you can work out why it's flawed and you can solve it without destroying the map's visuals and all of its functionalities, then you're welcome to release it, but only one version please. From now on indefinitely, I'm 100% washing my hands of it and UT99 because I have other things I wish to focus my attention on.

I'm done with mapping for UT, you'll not see me again. I've done my best with it and I have no more to give. Thank you to all who helped me with it and I'm so sorry it's come to this. :sad2:
darksonny
Adept
Posts: 471
Joined: Sat Sep 13, 2008 10:24 pm

Re: CTF-[R3P]-W007-III Fail.

Post by darksonny »

R3plicant wrote: Sat Mar 25, 2023 3:08 pm
The (flawed) map file is linked here


Well, I don't know what to say. I have had to see sense and realise I'm just not a good mapper. This is a 'sense' quit rather than a rage quit, I see no more sense in trying to get this map to work; it's a failure as it persists in lagging in-game, in both SP and in MP modes despite my very best efforts and the efforts of others who've helped me. It's unplayable in its current state.

The map is lagging like a ***** and I just cannot for the life of me, work out what's actually causing it. I've spent many, many hours working intensely with the brilliant, patient Buggie, ridiculously clever Aspide and bot-pathing god Sektor and had advice from Hourences and Lode to hopefully get the map to state that I was happy with but I realise now that's not gonna happen, the map is, somehow, fundamentally flawed and I cannot work out why.

My only guess is it's a poly count issue, I know it's a busy map with lots of beautiful detail (if I say so myself) - did I push the engine too far? *Rhetorical question. The simple answer to my own question though is: Maybe, yes.

The map file is linked here with all the associated files. If you want to try and get it running smoothly, by my guest, I want no more to do with it. The link won't be active for too long so I suggest you save it and maybe make it available elsewhere but with this post attached so people know why it's being made available.

If you can work out why it's flawed and you can solve it without destroying the map's visuals and all of its functionalities, then you're welcome to release it, but only one version please. From now on indefinitely, I'm 100% washing my hands of it and UT99 because I have other things I wish to focus my attention on.

I'm done with mapping for UT, you'll not see me again. I've done my best with it and I have no more to give. Thank you to all who helped me with it and I'm so sorry it's come to this. :sad2:
Hey hey dude! what happened here? I tested your map and I find this map very sexy aesthetically (knowing its a very old uengine and you have sequeezed and pushed to the limits), I do like those lightning effects. Very clean I do like a lot and I love woot maps like this. Whats the problem? Maybe mappers still active here could help you.


also, it would be nice to see mappers like you to keep alive ut now is delisted :(
pd
Is still open the contest to renew the stock ut maps? anybody knows something?
I run under win 10 and 11 with 24 gb ram/ryzen 9 5900 and mobo asrock taichi ultimate x470 the map runs well no lag At net I'll have to test it (quadro 7000)
User avatar
FraGnBraG
Inhuman
Posts: 930
Joined: Sun Jun 13, 2010 5:13 pm
Personal rank: Good news everyone!
Location: Canada

Re: CTF-[R3P]-W007-III Fail.

Post by FraGnBraG »

Ah, Replicant! how are you man :) I just loaded it up played 3 matches with masterfuls and I had no issues at all. A few niggles (i find the map too dark - and thus hard to aim and much falling death). I also am deadfast that woot maps should have proper sized woot pads with arrows - as per the extreme woot spec. Anyways, that's just me. It's not a bad woot map though, seem to work alright. I played with 2 teams of 4 - no crazy polys/node counts, or crazy lag spikes. I'll take a look in the editor tomorrow see if i notice anything... there could be homs and bad cuts etc which iirc can cause lagging...

I've actually been playing ut99 occasionally over the last two weeks and seem to be having fun revisiting my "keeper" collection. Some sweet maps in that folder :) kinda miss the ol' gameplay and short level-loading times. I do miss this graphic environment too, simplistic as it is (csg/bsp rather than mesh-based) there are some nice custom themes! Anyways, just to say I was looking at a bunch of unfinished projects I have - maybe I'll continue one or two -see how that goes. Give the RPGs a rest for a spell :)
-=FraGnBraG Level Design=- ***UPDATED! even works on your phone!***
User avatar
smeerkat
Skilled
Posts: 151
Joined: Sat Apr 04, 2009 6:00 pm
Personal rank: DHR
Location: Canada

Re: CTF-[R3P]-W007-III Fail.

Post by smeerkat »

I reviewed CTF W007 ][ four years ago. I love the visuals in version 3; the only thing I could think of is there are a couple of spots when you are outside where nodes exceed 1000 and polys over 700. I have a pretty beefy PC, so I guess you're pushing the limits of the UT99 engine.
darksonny
Adept
Posts: 471
Joined: Sat Sep 13, 2008 10:24 pm

Re: CTF-[R3P]-W007-III Fail.

Post by darksonny »

FraGnBraG wrote: Sun Mar 26, 2023 4:58 am Ah, Replicant! how are you man :) I just loaded it up played 3 matches with masterfuls and I had no issues at all. A few niggles (i find the map too dark - and thus hard to aim and much falling death). I also am deadfast that woot maps should have proper sized woot pads with arrows - as per the extreme woot spec. Anyways, that's just me. It's not a bad woot map though, seem to work alright. I played with 2 teams of 4 - no crazy polys/node counts, or crazy lag spikes. I'll take a look in the editor tomorrow see if i notice anything... there could be homs and bad cuts etc which iirc can cause lagging...

I've actually been playing ut99 occasionally over the last two weeks and seem to be having fun revisiting my "keeper" collection. Some sweet maps in that folder :) kinda miss the ol' gameplay and short level-loading times. I do miss this graphic environment too, simplistic as it is (csg/bsp rather than mesh-based) there are some nice custom themes! Anyways, just to say I was looking at a bunch of unfinished projects I have - maybe I'll continue one or two -see how that goes. Give the RPGs a rest for a spell :)
UT never dies dude! XD
it's like rock'n'roll, they never die!
Nice to see you here!
User avatar
sektor2111
Godlike
Posts: 6424
Joined: Sun May 09, 2010 6:15 pm
Location: On the roof.

Re: CTF-[R3P]-W007-III Fail.

Post by sektor2111 »

Um... I'm not here, Paths have been rebuild and this way is not my way... Somebody went busy to add dumb completions to my work which were not needed.
Right now I don't understand why I worked here (wasting time) because is nothing left from what I did + adding more BS.

Code: Select all

LostData: ________________________________________________________________
LostData: ReachSpecs missing from PrunedPaths[0-15] 	= 144.
FixedWithSuccess: ReachSpecs successfully attached 	= 0.
FixFailures: ReachSpecs attaching failures - probably no place = 144.
LostData: ________________________________________________________________
Not my doing... The "Dev" used here for these paths disrupted UDamage and added more useless data - such as paths going out of "Pads" in multiple directions.
Version which I sent you has full links and NO Pruned Trash from any sort.
It was a Teleporting issue with telefragging which made me to solve it by pushing it upper and disconnecting all "pass-through" routing for destination point from Spawn Rooms - smoothly kicking Pawn from Teleporter range. Here I see them back on the ground, no more kicks, and then... Where is my Pathing ? It flew on Window.

Generic message: Any potential UT virtual version 500 won't do paths automated like user does manually. Script doesn't have eyes, brain and simply doesn't know what you want even if you speak english perfectly...
The rest is image evidences:
My Doing:
W007_1.PNG
Followed by this PathsChecker report

Code: Select all

ScanProcess: Total checks using DevPath = 3536.
Greetings: All 136 targets look reachable from every single PlayerStart.
Map-File being 37.3 MB.

And this version:
W007_2.PNG

Code: Select all

ScanProcess: Total checks using DevPath = 2992.
Flaws: There were 44 attempts to reach at inventories.
Map-File being 50.9 MB.
You do not have the required permissions to view the files attached to this post.
User avatar
esnesi
Godlike
Posts: 1020
Joined: Mon Aug 31, 2015 12:58 pm
Personal rank: Dialed in.

Re: CTF-[R3P]-W007-III Fail.

Post by esnesi »

Sadly the same happens every 3-4 years or so..
R3P decides to revamp w007, something doesn't work out and he leaves again.

It's not a bad guy (based on his posts) and a genius mapper.
I wish he could map more casual instead of emotional.
Easier said then done for some ofcourse.

We are still rocking the w007 2018 Insta version on FFN :rock:
User avatar
Aspide
Skilled
Posts: 193
Joined: Wed Jun 09, 2021 12:13 am

Re: CTF-[R3P]-W007-III Fail.

Post by Aspide »

Oh man, sad that it came to this, I was really looking forward to this map, I helped to fix the map but it seems that it was never enough...., I will still play the map however, this one is still a keeper :tu:
Somewhere in Nevada...
Red_Fist
Godlike
Posts: 2175
Joined: Sun Oct 05, 2008 3:31 am

Re: CTF-[R3P]-W007-III Fail.

Post by Red_Fist »

I extended the bottom large zone brush so it sticks out 2 units, fixed that big black ass spot on that sheet at the bottom.

I moved those outside bases down and away and sideways away from the center so no lines from other brushes are parallel (out of the way)
By doing that the zone inside changed color and the holes in the fakebackdrop went away. I need to point out here, is that those outside bases should not be changing the zone inside after I moved them.

The outside bases are built wrong, plus the engine isn't well fitted for those suspending zones inside as well. And or, wasn't meant to do that but works, it's supposed to be a zone sheet to chop off areas

Way I see it, those outside bases need a rebuild as a structure with maybe 3 zones each. This map has 58 zones.
If you count inside plus skybox, is 7 zones. Lets say 6 zones for both bases, So this map should not have more than 20 zones MAX !!! or less like 15 or 12.

The outer area is impractical for being so large, and there is as good or better ways to kill falling players AND still keep a good skybox, without HUGE friggen walls and so TALL. I think those are the main problems, the size of the play area, and poorly made bases adding zones but not made bad, but made from an engines point of view. They should be contained away from space without trying to zone your way all over the place, or getting new unneeded zones. All those effect windows don't need to be zones and those zone actors. The place the teleporter comes up, below does not need to be a zone.

Try much smaller area brush and use cloudzones, then the bullets disappear and players die.

I deleted the coronas, the green light bar brushes below, the monitors and all the brushes around it. Seems to always have slow FPS. I also increased the center zone, wider , seemed the same. and a few other things, stayed the same.

So that leaves all those zones and large surfaces, and by combo building it with suspended zones, I think it's throwing off the engine, taxing it when it isn't supposed to be utilized the way you did the map, I remember the map too.

I just think those bases could look identical but with 3/4 less polys and 15 less zones, I also don't see how you crammed in 2010 brushes, seems overkill, maybe not.
Last edited by Red_Fist on Mon Mar 27, 2023 8:05 am, edited 3 times in total.
Binary Space Partitioning
User avatar
sektor2111
Godlike
Posts: 6424
Joined: Sun May 09, 2010 6:15 pm
Location: On the roof.

Re: CTF-[R3P]-W007-III Fail.

Post by sektor2111 »

As far as I read what was written and thinking a bit, zones need some considerations. Portals usually are matching some windows, doors, hallways, generally NARROW holes. Engine does queries what is being visible through portals. Let me see... there are more traces and more processing when portals are HUGE, instead of speeding up rendering it will go in opposite direction for processing portals without any real benefit in performance terms. I might be wrong here but for me this Engine has its bubbles...
Recently I played a "Woot" map closer to this one (fixed of course), this is why this piece has captured my attention, but here I really got an ugly FPS drop especially when I'm looking at the other base, I cannot play it like that.
User avatar
Barbie
Godlike
Posts: 2849
Joined: Fri Sep 25, 2015 9:01 pm
Location: moved without proper hashing

Re: CTF-[R3P]-W007-III Fail.

Post by Barbie »

Red_Fist wrote: Mon Mar 27, 2023 6:57 am If you count inside plus skybox, is 7 zones. Lets say 6 zones for both bases, So this map should not have more than 20 zones MAX !!! or less like 15 or 12.
The number of zones is shown in UnrealEd > Build > Build Options > Stats > Zones. That shown value is capped at 63 - in this case there may be more zones: rebuild the map and have a look into Editor.log:
Editor.log wrote:Log: Found 89 zones
"If Origin not in center it be not in center." --Buggie
User avatar
FraGnBraG
Inhuman
Posts: 930
Joined: Sun Jun 13, 2010 5:13 pm
Personal rank: Good news everyone!
Location: Canada

Re: CTF-[R3P]-W007-III Fail.

Post by FraGnBraG »

...Found 89 zones...
wow. how do you have that many!? One thing to look for are the false zones created by mis-aligned brushwork. Actions like changing the grid settings from small to large (or vice versa) and accidentally nudging something can cause "gaps" and unexpected sealed zones. Sometimes semisolids cause this as well. Watch the coronas - these need to be managed. But ya seems like you have zone issues. Note also any zones/portals that are seen from camera perspective are rendered, iirc, thus you need to occlude visibility of zones if you need framerate (or to reduce visible node count). Tough to do with an open map like this one. Maybe increase wall-heights, or add more objects on the base floors to block visible polys in view. Some thought -- It's tricky...
-=FraGnBraG Level Design=- ***UPDATED! even works on your phone!***
User avatar
[NBK]DxTrEm3Fx
Adept
Posts: 259
Joined: Wed May 09, 2012 5:56 pm
Location: Glendale, AZ

Re: CTF-[R3P]-W007-III Fail.

Post by [NBK]DxTrEm3Fx »

Man, your map is pretty awesome R3P and I love it. Not sure what you can do to be satisfied with the results you have. I would love to put it on my server.
Image
Image
User avatar
Barbie
Godlike
Posts: 2849
Joined: Fri Sep 25, 2015 9:01 pm
Location: moved without proper hashing

Re: CTF-[R3P]-W007-III Fail.

Post by Barbie »

FraGnBraG wrote: Mon Mar 27, 2023 4:11 pm
...Found 89 zones...
wow. how do you have that many!?
Reason were some pillars that created "holes" which were treated as separate zones. See this post for details.
"If Origin not in center it be not in center." --Buggie
User avatar
sektor2111
Godlike
Posts: 6424
Joined: Sun May 09, 2010 6:15 pm
Location: On the roof.

Re: CTF-[R3P]-W007-III Fail.

Post by sektor2111 »

Facts which I know after making veeery few maps are a lot for making me to not step in a "brushing" competition. It would be off-topic to explain you that I had adjusted in a few hours a sort of test map in t3d format. All was "000000" and matching grid. After importing data you don't want to see how was imported by Mr. Goblin... I could see colors in BSPCut view and first time I thought that is a fake ViewPort image. Nah, after zooming I could clearly see brushes OFF GRID.
The question comes: How about complex formats if a charge of "CUBES-ONLY" has been flawed ? No, I just imported them without any touch and any movement - I think that T3D experiment was already posted somewhere for whoever wants to check himself/herself what I witnessed... Maybe your machines have a better deal at "Floating" numbers and CPU is better... for me it was way no way... I simply quit thinking at mapping something more... "designed", Goblin demotivated me.