Patch 469d for win XP not compatible with ACE1.2e ?

Discussions about UT99
User avatar
Patrick Bateman
Novice
Posts: 5
Joined: Tue Dec 19, 2023 2:55 pm

Patch 469d for win XP not compatible with ACE1.2e ?

Post by Patrick Bateman »

I am testing new final release of 469d patch for XP.
I made clean install of UT99 GOTY in separate folder, then installed high resolution S3TC textures and made useful tweaks (like advised here on ut99.org).
I tried to game online on Evil's (-=NFR=- Evil's Freestyle Sniper Deathmatch) server with 436 - it worked.
And then i installed 469d patch for XP. And i try to connect to Evil's server. I was kicked 2 times by ACE almost immediately after connection.
Here is the screenshot of what it saying:
Shot00004.png
There are other bugs that i find immediately after installing 469d, but i want to start here with most big one.
You do not have the required permissions to view the files attached to this post.
User avatar
Deepu
Adept
Posts: 350
Joined: Mon Nov 11, 2013 7:56 am
Personal rank: Average
Location: India

Re: Patch 469d for win XP not compatible with ACE1.2e ?

Post by Deepu »

I think ace need to be updated for arm, 64bit Linux and Win XP too, waiting for new ace.
Buggie
Godlike
Posts: 2657
Joined: Sat Mar 21, 2020 5:32 am

Re: Patch 469d for win XP not compatible with ACE1.2e ?

Post by Buggie »

It not related to patch. Stop use DirectInput for mouse. Use RawInput.
It is well-known bug of ACE and will be fixed in next release of ACE.
User avatar
Patrick Bateman
Novice
Posts: 5
Joined: Tue Dec 19, 2023 2:55 pm

Re: Patch 469d for win XP not compatible with ACE1.2e ?

Post by Patrick Bateman »

Buggie wrote: Thu Dec 21, 2023 6:48 pm It not related to patch. Stop use DirectInput for mouse. Use RawInput.
It is well-known bug of ACE and will be fixed in next release of ACE.
But i use direct input in 451 and 436 too. Why then ACE do not kick me when i use on every day basis 451+direct input?
Buggie
Godlike
Posts: 2657
Joined: Sat Mar 21, 2020 5:32 am

Re: Patch 469d for win XP not compatible with ACE1.2e ?

Post by Buggie »

No idea.
Anyway ACE must not trigger for this file.
User avatar
Patrick Bateman
Novice
Posts: 5
Joined: Tue Dec 19, 2023 2:55 pm

Re: Patch 469d for win XP not compatible with ACE1.2e ?

Post by Patrick Bateman »

Buggie wrote: Thu Dec 21, 2023 7:28 pm Anyway ACE must not trigger for this file.
"must not trigger for this file"?
I'm sorry, but i don't understand meaning of what you wrote. Please, can you say this in another form?
User avatar
UT Sniper (SJA94)
Inhuman
Posts: 753
Joined: Thu Jun 24, 2010 10:35 pm
Personal rank: Retard
Location: England

Re: Patch 469d for win XP not compatible with ACE1.2e ?

Post by UT Sniper (SJA94) »

ACE is not supposed to kick players for using direct input, it's a bug with ACE itself and not the 469 patch, the only thing different in 469 is that direct input uses the lastest version of it(DirectX8), microsoft themselves don't recommend using direct input for the last 12 years at least.

Code: Select all

As of 2011 Microsoft no longer recommends using DirectInput for keyboards or mice
User avatar
Delacroix
Adept
Posts: 300
Joined: Thu Mar 25, 2010 6:00 pm
Personal rank: UMS R&D CEO

Re: Patch 469d for win XP not compatible with ACE1.2e ?

Post by Delacroix »

ACE should damn well be updated already. People shouldn't be kicked for using the latest patch, period, be it a renderer, an input setting or the resources updated by 469 such as UMenu. It needs to be updated and distributed across servers. Doing otherwise will basically shut out anyone who dared upgrade. This isn't what is supposed to happen.