-->aqueen<--- the package does not match

Discussions about UT99
buby
Average
Posts: 39
Joined: Thu Feb 23, 2017 1:07 am

-->aqueen<--- the package does not match

Post by buby »

Hi guys, just an help.
After downloaded UtCacheCleaner and try to play with UT I have on alert about "aqueen" (package does not match).
Is there a solution?

Thanks
User avatar
TankBeef
Masterful
Posts: 586
Joined: Tue Apr 13, 2021 12:56 am

Re: -->aqueen<--- the package does not match

Post by TankBeef »

Ok, first of all, mismatches with cache cleaning are fairly common, so, if there is a map, skin, model, mod, etc.that you like, it is preferable to look for it in unrealarchive.org.
See if this helps: https://unrealarchive.org/files/4d/4d02 ... 0812d.html
Buggie
Godlike
Posts: 2726
Joined: Sat Mar 21, 2020 5:32 am

Re: -->aqueen<--- the package does not match

Post by Buggie »

Look like with UtCacheCleaner you move all files from cache to your UT folder. In general it is bad idea. Now on each such error you need search over your UT folder and delete mismatched file. After that try reconnect to server again.

In current case it be aqueen.u in System.

Also I advice update game to latest version (v469c at now) https://github.com/OldUnreal/UnrealTour ... ses/latest
This allow you download from server own version of file, even if you installed some other version in game. Almost in all cases. If this not help anyway, you still need delete file.
User avatar
Shrimp
Adept
Posts: 273
Joined: Wed Oct 10, 2018 11:15 am
Location: Australia

Re: -->aqueen<--- the package does not match

Post by Shrimp »

There's also 2 version of the file. One's 1kb bigger than the other:

https://unrealarchive.org/packages/unre ... index.html
ShrimpWorks
Unreal Archive - preserving over 25 years of user-created content for the Unreal series!
buby
Average
Posts: 39
Joined: Thu Feb 23, 2017 1:07 am

Re: -->aqueen<--- the package does not match

Post by buby »

Buggie wrote: Sat Dec 31, 2022 8:52 am Look like with UtCacheCleaner you move all files from cache to your UT folder. In general it is bad idea. Now on each such error you need search over your UT folder and delete mismatched file. After that try reconnect to server again.

In current case it be aqueen.u in System.

Also I advice update game to latest version (v469c at now) https://github.com/OldUnreal/UnrealTour ... ses/latest
This allow you download from server own version of file, even if you installed some other version in game. Almost in all cases. If this not help anyway, you still need delete file.
Thanks for your advice, but in the UT folder (main directory) I haven't aqueen.u, but olny cache**.tmp files. The aqueen.u file is located in the system folder (.../UnrealTournament/System/aqueen.u).
User avatar
Que
Inhuman
Posts: 788
Joined: Mon Dec 09, 2019 5:49 am
Personal rank: ...

Re: -->aqueen<--- the package does not match

Post by Que »

yeah delete that and reconnect.
*Join our Discord Here.*
Our mods - MVX , SSB , SmartWFL , UTCmds , BotCommands , Smart Stats , join/leave announcer , NoSmoke , UTLogin , BrightSkins , Server Tran…
*Our Servers
User avatar
papercoffee
Godlike
Posts: 10446
Joined: Wed Jul 15, 2009 11:36 am
Personal rank: coffee addicted !!!
Location: Cologne, the city with the big cathedral.

Re: -->aqueen<--- the package does not match

Post by papercoffee »

buby wrote: Sat Dec 31, 2022 9:54 am Thanks for your advice, but in the UT folder (main directory) I haven't aqueen.u, but olny cache**.tmp files. The aqueen.u file is located in the system folder (.../UnrealTournament/System/aqueen.u).
uhm...
Buggie wrote: Sat Dec 31, 2022 8:52 am In current case it be aqueen.u in System.
That's what he meant... So, did it solve it?
User avatar
sektor2111
Godlike
Posts: 6410
Joined: Sun May 09, 2010 6:15 pm
Location: On the roof.

Re: -->aqueen<--- the package does not match

Post by sektor2111 »

The same scenario with other actors. You can forget forever un-caching content in client used for playing over network - except client specific stuff. UnCaching generally is a bad idea for clients - PLAYERS. If we speak about modders/coders, they are the only ones helped by these "applications", which should come with a manual explaining the "Cave-At" behind using them. I have only a giant Cache folder placed even outside of UT folder with UXX files, but the rest of folders have nothing else than stock and a custom console (XConsole more exactly) plus other assets that are not doing damage at network gaming generally (XC_Engine).
TMP files - you can delete them all.
UXX files - leave them alone, you can even set then as "Read-Only". And yes these files are used without re-downloading them if required versions are matching what server is having.
User avatar
Feralidragon
Godlike
Posts: 5493
Joined: Wed Feb 27, 2008 6:24 pm
Personal rank: Work In Progress
Location: Liandri

Re: -->aqueen<--- the package does not match

Post by Feralidragon »

Or you could just update the game to v469 and not have to deal with package mismatches at all.
buby
Average
Posts: 39
Joined: Thu Feb 23, 2017 1:07 am

Re: -->aqueen<--- the package does not match

Post by buby »

Well, I deleted this file and everything appear working good.
Another question for those who have suggested to update to v469c: have I to download all these files: OldUnreal-UTPatch469c-Windows-WinDrv-Hotfix.zip - OldUnreal-UTPatch469c-Windows.exe - OldUnreal-UTPatch469c-Windows.zip ?

PS.
Normally playing with UT I see that many servers have version 451 so is the new version compatible with older?
Buggie
Godlike
Posts: 2726
Joined: Sat Mar 21, 2020 5:32 am

Re: -->aqueen<--- the package does not match

Post by Buggie »

OldUnreal-UTPatch469c-Windows.exe or OldUnreal-UTPatch469c-Windows.zip
After apply OldUnreal-UTPatch469c-Windows-WinDrv-Hotfix.zip

Compatible. Even with v436 servers and clients.
buby
Average
Posts: 39
Joined: Thu Feb 23, 2017 1:07 am

Re: -->aqueen<--- the package does not match

Post by buby »

Waiting to update the game I have had a doubt: if the game works properly, if I have not any crashes, if sound works what are the reason to upgrade?

Thanks for your suggestions ...and Happy New Year!
User avatar
TankBeef
Masterful
Posts: 586
Joined: Tue Apr 13, 2021 12:56 am

Re: -->aqueen<--- the package does not match

Post by TankBeef »

buby wrote: Sun Jan 01, 2023 7:12 pm Waiting to update the game I have had a doubt: if the game works properly, if I have not any crashes, if sound works what are the reason to upgrade?

Thanks for your suggestions ...and Happy New Year!
Well, not sure if you read this on the github, but I will copy paste it:

Besides fixing hundreds of bugs, the OldUnreal UT patches also add features such as:

Raw input support and full mouse smoothing control
OldUnreal's latest OpenGL 4-based 3D renderer (XOpenGLDrv)
OldUnreal's latest OpenAL-based audio driver (ALAudio)
Han's latest FMOD-based audio driver (Cluster)
SDL2-based window management for the Linux and macOS clients
The latest Demo Manager
Unreal 227's Unreal Editor 2.2 (with many UT-specific enhancements)
PNG support for screenshots
Scaling control for in-game fonts and the game menu
UTF-8 support for game ini, int, and log files
Faster server downloads (even without redirect servers)
Mouse wheel scrolling support for the game menu
High-DPI awareness for the game and Unreal Editor
Updated versions of Chris Dohnal's UTGLR OpenGLDrv and D3D9Drv renderers
An updated in-game server browser with lots of quality-of-life improvements
User avatar
OjitroC
Godlike
Posts: 3613
Joined: Sat Sep 12, 2015 8:46 pm

Re: -->aqueen<--- the package does not match

Post by OjitroC »

buby wrote: Sun Jan 01, 2023 7:12 pm Waiting to update the game I have had a doubt: if the game works properly, if I have not any crashes, if sound works what are the reason to upgrade?

Thanks for your suggestions ...and Happy New Year!
You can try the patch out by duplicating your /System folder and installing the patch in one of the two folders (obviously renaming one of the 2 folders something other than System).

I have three installations - 436, 451 and 469c - with 3 System folders, with the version I use currently (469c) in a folder named System - the other 2 are in System436 and System451. To use one of the these versions, I rename the current System folder System469 and change the name of the one I want to use to System.

There are lots of benefits in using 469c, some of them are not so apparent - it will load 100s or even 1000s of maps in the map selection window (when playing off-line) much quicker than the other 2 versions (in fact one version won't even load the number that 469 will). If you use the code window in the Editor (as I do) you will find that 469 now correctly opens and closes classes unlike 436.

469c is more stable and more likely to handle errors in-game than the other two versions. The GUI can now be scaled which looks better and is easier to use - you can mouse scroll down lists of maps, mutators, etc unlike the other two versions.

So many benefits especially if you have newer hardware or a newer OS (not that I do though but I still find it better overall). It is certainly worth trying to see if you like it.
User avatar
Feralidragon
Godlike
Posts: 5493
Joined: Wed Feb 27, 2008 6:24 pm
Personal rank: Work In Progress
Location: Liandri

Re: -->aqueen<--- the package does not match

Post by Feralidragon »

buby wrote: Sun Jan 01, 2023 7:12 pm Waiting to update the game I have had a doubt: if the game works properly, if I have not any crashes, if sound works what are the reason to upgrade?
Besides what other people highlighted above:
  • you wouldn't have any problems related with mismatching packages like you did now in the first place (this would be the obvious one in this case);
  • it is substantially faster overall, especially in rendering, which makes a huge difference for some of the most intense mods;
  • it also has most crashes solved, which is also especially noticeable with more intense mods;
  • is tailored to be used in more modern systems: if you have a fairly recent computer (last 5 years), using v469 is preferable since it solves a lot of issues related with new systems;
  • it's also more secure: it has a bunch of severe security exploits that could compromise your install or even your whole system, and while some of them are still open, the overall number of known ones were fixed;
  • it brings some new features, meaning that for some new content (mods, maps) that you may want to try out, you may actually be required to update;
  • brings a much better editor to create maps and mods (if you ever intend to create anything, is best to use the latest editor, in order to save you a lot of pain from editor bugs and lack of important features from the previous version).
There are more, like faster downloads from servers and such, but those were already referred before, so not going to repeat them. :)

Either way, is best to use the most updated one, however, like also suggested before, you can just have multiple installations of the game at different versions, and you can try the new version yourself without having to compromise an existing install.